import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:https?:\\/\\/)?(?:(?:www\\.)?youtube\\.com\\/(?:(?:v\\/)|(?:embed\\/|watch(?:\\/|\\?)){1,2}(?:.*v=)?|.*v=)?|(?:www\\.)?youtu\\.be\\/)([A-Za-z0-9_\\-]+)&?.*$";
final String string = "http://www.youtube.com/watch/iwGFalTRHDA\n"
+ "http://www.youtube.com/v/iwGFalTRHDA\n"
+ "http://www.youtube.com/v/i_GFalTRHDA\n"
+ "http://www.youtube.com/watch?v=i-GFalTRHDA&feature=related \n"
+ "http://www.youtube.com/attribution_link?u=/watch?v=aGmiw_rrNxk&feature=share&a=9QlmP1yvjcllp0h3l0NwuA\n"
+ "http://www.youtube.com/attribution_link?a=fF1CWYwxCQ4&u=/watch?v=qYr8opTPSaQ&feature=em-uploademail\n"
+ "http://www.youtube.com/attribution_link?a=fF1CWYwxCQ4&feature=em-uploademail&u=/watch?v=qYr8opTPSaQ\n"
+ "http://www.youtube.com/watch?v=iwGFalTRHDA \n"
+ "https://www.youtube.com/watch?v=iwGFalTRHDA \n"
+ "http://www.youtube.com/watch?v=iwGFalTRHDA&feature=related \n"
+ "http://youtu.be/iwGFalTRHDA \n"
+ "http://www.youtube.com/embed/watch?feature=player_embedded&v=iwGFalTRHDA\n"
+ "http://www.youtube.com/embed/watch?v=iwGFalTRHDA\n"
+ "http://www.youtube.com/embed/v=iwGFalTRHDA\n"
+ "http://www.youtube.com/watch?feature=player_embedded&v=iwGFalTRHDA\n"
+ "http://www.youtube.com/watch?v=iwGFalTRHDA\n"
+ "www.youtube.com/watch?v=iwGFalTRHDA \n"
+ "www.youtu.be/iwGFalTRHDA \n"
+ "youtu.be/iwGFalTRHDA \n"
+ "youtube.com/watch?v=iwGFalTRHDA ";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}