# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:https?:\/\/)?(?:(?:www\.)?youtube\.com\/(?:(?:v\/)|(?:embed\/|watch(?:\/|\?)){1,2}(?:.*v=)?|.*v=)?|(?:www\.)?youtu\.be\/)([A-Za-z0-9_\-]+)&?.*$"
test_str = ("http://www.youtube.com/watch/iwGFalTRHDA\n"
"http://www.youtube.com/v/iwGFalTRHDA\n"
"http://www.youtube.com/v/i_GFalTRHDA\n"
"http://www.youtube.com/watch?v=i-GFalTRHDA&feature=related \n"
"http://www.youtube.com/attribution_link?u=/watch?v=aGmiw_rrNxk&feature=share&a=9QlmP1yvjcllp0h3l0NwuA\n"
"http://www.youtube.com/attribution_link?a=fF1CWYwxCQ4&u=/watch?v=qYr8opTPSaQ&feature=em-uploademail\n"
"http://www.youtube.com/attribution_link?a=fF1CWYwxCQ4&feature=em-uploademail&u=/watch?v=qYr8opTPSaQ\n"
"http://www.youtube.com/watch?v=iwGFalTRHDA \n"
"https://www.youtube.com/watch?v=iwGFalTRHDA \n"
"http://www.youtube.com/watch?v=iwGFalTRHDA&feature=related \n"
"http://youtu.be/iwGFalTRHDA \n"
"http://www.youtube.com/embed/watch?feature=player_embedded&v=iwGFalTRHDA\n"
"http://www.youtube.com/embed/watch?v=iwGFalTRHDA\n"
"http://www.youtube.com/embed/v=iwGFalTRHDA\n"
"http://www.youtube.com/watch?feature=player_embedded&v=iwGFalTRHDA\n"
"http://www.youtube.com/watch?v=iwGFalTRHDA\n"
"www.youtube.com/watch?v=iwGFalTRHDA \n"
"www.youtu.be/iwGFalTRHDA \n"
"youtu.be/iwGFalTRHDA \n"
"youtube.com/watch?v=iwGFalTRHDA ")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.