re = /[A-Za-z-.]{1,}@{1}[A-Za-z-]{2,}.{1}[A-Za-z-]{2,}/
str = 'Jean-Martial Sabot;lportaux@msi-nord.fr'
# Print the match result
str.match(re) do |match|
puts match.to_s
end