// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[A-Za-z-.]{1,}@{1}[A-Za-z-]{2,}.{1}[A-Za-z-]{2,}").unwrap();
let string = "Jean-Martial Sabot;lportaux@msi-nord.fr";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}