const regex = /^(.{2,32})#(?!0000)(\d{4})$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.{2,32})#(?!0000)(\\d{4})$', '')
const str = `Discord#0001`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
    // The result can be accessed through the `m`-variable.
    m.forEach((match, groupIndex) => {
        console.log(`Found match, group ${groupIndex}: ${match}`);
    });
}