$re = '/^(.{2,32})#(?!0000)(\d{4})$/';
$str = 'Discord#0001';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);