package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)مذلت|ذلت`)
var str = `۱. [اخلاق]ذلت
۲. [اخلاق، تصوف، مذهب]مذلت`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}