$re = '/مذلت|ذلت/m';
$str = '۱. [اخلاق]ذلت
۲. [اخلاق، تصوف، مذهب]مذلت';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);