$re = '/^aa(.+)cc(dd)\1$/m';
$str = 'aaHELLOccddGOODBYE
aaHELLOccddHELLO
aaHELLOccddGOODBYE
aaHELLOccddHELLO
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);