re = /^aa(.+)cc(dd)\1$/m
str = 'aaHELLOccddGOODBYE
aaHELLOccddHELLO
aaHELLOccddGOODBYE
aaHELLOccddHELLO
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end