using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?:.*?\|\s?){3})(.+?)(?:(?=\s?$)|(?=\s?\|))";
string input = @"String1 |String two is here| String 3 |[String-4]";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}