const regex = /(?:(?:.*?\|\s?){3})(.+?)(?:(?=\s?$)|(?=\s?\|))/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:.*?\\|\\s?){3})(.+?)(?:(?=\\s?$)|(?=\\s?\\|))', 'i')
const str = `String1 |String two is here| String 3 |[String-4]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}