using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=https:\/\/example\.com\/)([\w\-]+((?=\/\w+)\/|\b))+";
string input = @"https://example.com/awesome
https://example.com/awesome/path
https://example.com/aweso-me/path/
https://example.com/awesome/path?arg1=123";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}