$re = '/(?<=https:\/\/example\.com\/)([\w\-]+((?=\/\w+)\/|\b))+/m';
$str = 'https://example.com/awesome
https://example.com/awesome/path
https://example.com/aweso-me/path/
https://example.com/awesome/path?arg1=123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);