package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^A-Za-z]|\b)+DR([^A-Za-z]|\b)+`)
var str = `DR. This is my test string I want to match dr occurences of the case-sensitive word DR. I want all matches where DR is by itself and not part of a word such as DRIFT. I want to find it in the start of and end of a string. DR`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}