import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(0[1-9]|[12][0-9]|3[01])[-\\/.](0[1-9]|1[012])[-\\/.](200[2-9])$";
final String string = "01/01/1999\n"
+ "01/01/2000\n"
+ "01/01/2001\n"
+ "01/01/2002\n"
+ "01/01/2003\n"
+ "01/01/2004\n"
+ "01/01/2005\n"
+ "01/01/2006\n"
+ "01/01/2007\n"
+ "01/01/2008\n"
+ "01/01/2009\n"
+ "31/12/2009\n"
+ "01/01/2010\n"
+ "01/01/2011\n"
+ "01/01/2012\n"
+ "01/01/2013\n"
+ "01/01/2014\n"
+ "01/01/2015\n"
+ "01/01/2016\n"
+ "01/01/2017\n"
+ "01/01/2018\n"
+ "01/01/2019\n"
+ "01/01/2020\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}