import re
regex = re.compile(r"^(0[1-9]|[12][0-9]|3[01])[-\/.](0[1-9]|1[012])[-\/.](200[2-9])$", flags=re.MULTILINE)
test_str = ("01/01/1999\n"
"01/01/2000\n"
"01/01/2001\n"
"01/01/2002\n"
"01/01/2003\n"
"01/01/2004\n"
"01/01/2005\n"
"01/01/2006\n"
"01/01/2007\n"
"01/01/2008\n"
"01/01/2009\n"
"31/12/2009\n"
"01/01/2010\n"
"01/01/2011\n"
"01/01/2012\n"
"01/01/2013\n"
"01/01/2014\n"
"01/01/2015\n"
"01/01/2016\n"
"01/01/2017\n"
"01/01/2018\n"
"01/01/2019\n"
"01/01/2020\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")