$re = '/^(?!.*\b(?:com|dot)\b).+/m';
$str = 'main for com
main for dot
main to dot
main to com
maincom
maindot';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);