re = /^(?!.*\b(?:com|dot)\b).+/m
str = 'main for com
main for dot
main to dot
main to com
maincom
maindot'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end