package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)- (.*)`)
var str = `September 2014 - Media`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}