$re = '/- (.*)/m';
$str = 'September 2014 - Media';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);