package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\[cid=(?:\d*)(?:(?:,\[[^\]]*\][^\]]*)?|(?:,[^\]]*))\])`)
var str = `[cid=5555,[CONSTIMG]5555.jpg]The Sample text is awesome`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}