const regex = /(\[cid=(?:\d*)(?:(?:,\[[^\]]*\][^\]]*)?|(?:,[^\]]*))\])/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\[cid=(?:\\d*)(?:(?:,\\[[^\\]]*\\][^\\]]*)?|(?:,[^\\]]*))\\])', '')
const str = `[cid=5555,[CONSTIMG]5555.jpg]The Sample text is awesome`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}