const regex = /\b\"\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\"\\b', 'gm')
const str = `""comment_text": "Siti Sa"diah I need this for my neighbor needs""`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);