$re = '/\b\"\b/m';
$str = '""comment_text": "Siti Sa"diah I need this for my neighbor needs""';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;