package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*Clerk\s*1\s*([^\s]+)\s*([^\s]+)`)
var str = `Clerk 1 Koilakos Panagiotis Ioannis `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}