re = /\s*Clerk\s*1\s*([^\s]+)\s*([^\s]+)/m
str = 'Clerk 1 Koilakos Panagiotis Ioannis '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end