using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#[0123456789abcdef]";
string input = @"#c5c5c5";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}