package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)#[0123456789abcdef]`)
var str = `#c5c5c5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}