using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"SPECGRID.*?\n([ \d]+)[\s\S]*?\/";
string input = @"-- Generated [
-- Format : ECLIPSE keywords (grid geometry and properties) (ASCII)
-- Exported by : Petrel 2014.4 (64-bit) Schlumberger
-- User name : apitchford
-- Date : Friday, April 29 2016 15:20:42
-- Project : Glenloth19April2016.pet
-- Grid : Tartan Wide 3D grid 150 prop
-- Generated ]
PINCH -- Generated : Petrel
/
MAPUNITS -- Generated : Petrel
METRES /
MAPAXES -- Generated : Petrel
156653.33 7788633.76 156653.33 7789633.76 157653.33 7789633.76 /
GRIDUNIT -- Generated : Petrel
METRES /
SPECGRID -- Generated : Petrel
54 166 127 1 F /
COORDSYS -- Generated : Petrel
1 127 /";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}