$re = '/SPECGRID.*?\n([ \d]+)[\s\S]*?\//';
$str = '-- Generated [
-- Format : ECLIPSE keywords (grid geometry and properties) (ASCII)
-- Exported by : Petrel 2014.4 (64-bit) Schlumberger
-- User name : apitchford
-- Date : Friday, April 29 2016 15:20:42
-- Project : Glenloth19April2016.pet
-- Grid : Tartan Wide 3D grid 150 prop
-- Generated ]
PINCH -- Generated : Petrel
/
MAPUNITS -- Generated : Petrel
METRES /
MAPAXES -- Generated : Petrel
156653.33 7788633.76 156653.33 7789633.76 157653.33 7789633.76 /
GRIDUNIT -- Generated : Petrel
METRES /
SPECGRID -- Generated : Petrel
54 166 127 1 F /
COORDSYS -- Generated : Petrel
1 127 /';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);