$re = '/(?=({(?>[^{}]|(?1))+}))/';
$str = 'Hello World {foo{bar}} World Hello!
{first{second{third}second}first}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);