import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+/\\w{32}\\.html";
final String string = "history/2c0b65635b3ac68a4d53b89521216d26.html\n"
+ "history/2c0b65635b3ac68a4d53b89521216d26_0.html\n"
+ "marketing/3c0a65635b2bc68b5c43b88421306c37.html\n"
+ "marketing/3c0a65635b2bc68b5c43b88421306c37_0.html";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}