const regex = /((?:https?:\/\/)?(?:www\.)?youtu\.?be(?:\.com)?\/(?!.*[?&]v=).*(?:list=)([\w-_]+)[^\s\'\"\.]*)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:https?:\\\/\\\/)?(?:www\\.)?youtu\\.?be(?:\\.com)?\\\/(?!.*[?&]v=).*(?:list=)([\\w-_]+)[^\\s\\\'\\"\\.]*)', 'gmi')
const str = `https://www.youtube.com/playlist?list=PLFgquLnL59akaNTxtgsoKn4c0Q8utjqku
http://www.youtube.com/embed/videoseries?list=PLdwCuEoZ_6l6C47ciTvf6Z2GArUOCHHQ3
https://www.youtube.com/watch?v=VTMcqVFk39s&index=2&list=PLxgKRG5rfVFa067PHSpju_XaTPiyii31L
https://www.youtube.com/watch?v=TpbTkbv4L2Y&list=PLvqxe4XbcSiEzrZm28NjsLXmHkffCJmBY&index=2
https://www.youtube.com/watch?index=2&list=PLxgKRG5rfVFa067PHSpju_XaTPiyii31L&v=VTMcqVFk39s
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}