re = /((?:https?:\/\/)?(?:www\.)?youtu\.?be(?:\.com)?\/(?!.*[?&]v=).*(?:list=)([\w-_]+)[^\s\'\"\.]*)/mi
str = 'https://www.youtube.com/playlist?list=PLFgquLnL59akaNTxtgsoKn4c0Q8utjqku
http://www.youtube.com/embed/videoseries?list=PLdwCuEoZ_6l6C47ciTvf6Z2GArUOCHHQ3
https://www.youtube.com/watch?v=VTMcqVFk39s&index=2&list=PLxgKRG5rfVFa067PHSpju_XaTPiyii31L
https://www.youtube.com/watch?v=TpbTkbv4L2Y&list=PLvqxe4XbcSiEzrZm28NjsLXmHkffCJmBY&index=2
https://www.youtube.com/watch?index=2&list=PLxgKRG5rfVFa067PHSpju_XaTPiyii31L&v=VTMcqVFk39s
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end