re = /(\w+?)_(\d+)(?:\.|$)/i
str = 'group_12.label:sub_1.field_23.label+long_field.label:another.label+long_field_345'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end