using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z0-9]+([^@][a-z0-9])*@[a-z0-9]{2,}([^@.][a-z0-9])*(\.[a-z]{2,}([^@.][a-z0-9])*)+$";
string input = @"test_test.test@test.test";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}