re = /^[a-z0-9]+([^@][a-z0-9])*@[a-z0-9]{2,}([^@.][a-z0-9])*(\.[a-z]{2,}([^@.][a-z0-9])*)+$/i
str = 'test_test.test@test.test'
# Print the match result
str.match(re) do |match|
puts match.to_s
end