package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\S+`)
var str = ` trogdor was a man or was he a dragon man `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}