$re = '/\S+/';
$str = ' trogdor was a man or was he a dragon man ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);