const regex = /(?:start:(?=\w+(?:-\w+){2,9}:end)|(?!^)\G-)(\w+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:start:(?=\\w+(?:-\\w+){2,9}:end)|(?!^)\\G-)(\\w+)', 'g')
const str = `-Should-not-match
Some text here and start:test-test-lorem-ipsum-sir-doloret-etc-something:end another something start:SIR-doloret-something:endand this is a non-match: start:SOMmething-blabla:end because hasn't got enough groups.
This also start:REST-doloret-etc-something:end but not this: start:XXYY-lorem-ipsum-sir-doloret-etc-something-8-nine-ten-eleven:end because i
t's too long. start:XXYY-lorem-ipsum-sir-doloret-etc-something-8-nine-ten:end just there, and also start:XXYY-lorem-ipsum:end-garbage
This shouldn-t match also start:nothing:end! start:nothing-next:end
Test start:Something-nine-ten-eleven:end-bla-blastart:REST-doloret-etc-something:end---`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}