const regex = /^(?!\/vendor(?:\/|$))(?!.*\bmin\.[^.]*$)(.*\.)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!\\\/vendor(?:\\\/|$))(?!.*\\bmin\\.[^.]*$)(.*\\.)', 'gm')
const str = ` --> DO NOT MATCH
/vendor/bootstrap/css/bootstrap.min.css
/vendor/font-awesome/font-awesome.min.css
/vendor/jquery/jquery.min.js
/vendor/bootstrap/js/bootstrap.min.js
/vendor/socket-io/library.js
--> MATCH
/js/index.js
/css/style.css
/some/other/script.js
/js/index.min.js`;
const subst = `$1min.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);