$re = '/^(?!\/vendor(?:\/|$))(?!.*\bmin\.[^.]*$)(.*\.)/m';
$str = ' --> DO NOT MATCH
/vendor/bootstrap/css/bootstrap.min.css
/vendor/font-awesome/font-awesome.min.css
/vendor/jquery/jquery.min.js
/vendor/bootstrap/js/bootstrap.min.js
/vendor/socket-io/library.js
--> MATCH
/js/index.js
/css/style.css
/some/other/script.js
/js/index.min.js';
$subst = "$1min.";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;