const regex = /^(?=^[^_\n]+_?[^_\n]+$)\w{3,20}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=^[^_\\n]+_?[^_\\n]+$)\\w{3,20}$', 'gm')
const str = `gt_c
gt
g_t_c
gtc_
OnlyTwentyCharacters
poppy_harlow`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}