re = /^(?=^[^_\n]+_?[^_\n]+$)\w{3,20}$/m
str = 'gt_c
gt
g_t_c
gtc_
OnlyTwentyCharacters
poppy_harlow'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end