import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[\\s\\-\\_\\—\\–\\~\\(\\[\\{\\\"\\'\\‹\\«\\“\\‘\\¡\\¿\\/]?(AySA)[\\.\\,\\:\\;\\-\\_\\—\\–\\~\\s\\)\\]\\}\\\"\\'\\›\\»\\”\\’\\!\\?\\*\\/]?)";
final String string = "[START]\n"
+ "AySA \n"
+ "AySA,\n"
+ "AySA\n"
+ "AySA\n"
+ " AySA\n"
+ "-AySA\n"
+ "_AySA\n"
+ "—AySA\n"
+ "–AySA\n"
+ "~AySA\n"
+ "(AySA\n"
+ "[AySA\n"
+ "{AySA\n"
+ "‹AySA\n"
+ "«AySA\n"
+ "“AySA\n"
+ "‘AySA\n"
+ "¿AySA\n"
+ "¡AySA\n"
+ "/AySA\n\n\n"
+ "[END]\n"
+ "AySA\n"
+ "AySA\n"
+ "AySA,\n"
+ "AySA.\n"
+ "AySA \n"
+ "AySA-\n"
+ "AySA_\n"
+ "AySA—\n"
+ "AySA–\n"
+ "AySA~\n"
+ "AySA)\n"
+ "AySA]\n"
+ "AySA}\n"
+ "AySA›\n"
+ "AySA»\n"
+ "AySA”\n"
+ "AySA’\n"
+ "AySA?\n"
+ "AySA!\n"
+ "AySA/\n\n\n"
+ "[BOTH]\n"
+ "(AySA-\n"
+ "Esta nueva empresa, AySA. encargada\n\n"
+ "[INVALID]\n"
+ "AYSA\n"
+ "aysa\n"
+ "AySa\n"
+ "aYsA";
final String subst = "<abbr title=\"Agua y Saneamiento Argentina\">\\1</abbr>\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}