$re = '/(?:[\s\-\_\—\–\~\(\[\{\"\'\‹\«\“\‘\¡\¿\/]?(AySA)[\.\,\:\;\-\_\—\–\~\s\)\]\}\"\'\›\»\”\’\!\?\*\/]?)/m';
$str = '[START]
AySA
AySA,
AySA
AySA
AySA
-AySA
_AySA
—AySA
–AySA
~AySA
(AySA
[AySA
{AySA
‹AySA
«AySA
“AySA
‘AySA
¿AySA
¡AySA
/AySA
[END]
AySA
AySA
AySA,
AySA.
AySA
AySA-
AySA_
AySA—
AySA–
AySA~
AySA)
AySA]
AySA}
AySA›
AySA»
AySA”
AySA’
AySA?
AySA!
AySA/
[BOTH]
(AySA-
Esta nueva empresa, AySA. encargada
[INVALID]
AYSA
aysa
AySa
aYsA';
$subst = "<abbr title=\"Agua y Saneamiento Argentina\">\1</abbr>\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;