re = /\b[A-z]+(?=(, )|( or )|$)/
str = 'Hit that thing man! and a one, two, three, four, five, six, seven or eight'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end