package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([-+]?[0-9]*\.?[0-9]+[\/\+\-\*])+([-+]?[0-9]*\.?[0-9]+)`)
var str = `5+5
5-5
5*5
5/5
5*6/2
+500
-500
500
test
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}