re = /([-+]?[0-9]*\.?[0-9]+[\/\+\-\*])+([-+]?[0-9]*\.?[0-9]+)/
str = '5+5
5-5
5*5
5/5
5*6/2
+500
-500
500
test
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end